Antworten auf Ihre häufigsten Fragen

Wie kann ich die Sicherheitslücke DROWN (SSLv2/Verschlüsselung) schließen?
pdf print

(you can find an english version of this explanation below)

Im Februar 2016 wurde eine Sicherheitslücke in der SSL-Verschlüsselung unter dem Namen "DROWN" (Decrypting RSA with Obsolete and Weakened eNcryption, CVE-2016-0800) bekannt. Diese ermöglicht es ggf. einem Angreifer, verschlüsselten Datenverkehr entschlüsseln zu können, wie er z.B. zwischen Webbrowser und Webserver oder Mailprogramm und Mailserver Anwedung findet. Grundlage für den Angriff ist die serverseitige Unterstützung des veralteten SSLv2-Protokolls, die auch neuere, eigentlich sichere Verschlüsselungsverfahren angreifbar macht.

Was kann ich tun, wenn ich ein veraltetes Betriebssystem nutze?

Updates erscheinen nur für solche OS, die noch vom Hersteller mit solchen versorgt werden. Eine Übersicht zu den Lebenszyklen finden Sie hier. Sie können in diesem Fall zwar normalerweise SSLv2 deaktivieren, wir empfehlen allerdings generell (auch wegen anderer Sicherheitslücken) einen Wechsel auf ein aktuelles Betriebssystem, z.B. durch Neuinstallation oder Produktwechsel auf einen aktuellen Server (Produktwechsel Virtual Server). Wenn Sie also Ubuntu 10.04 (oder älter) oder Debian 6 (oder älter) nutzen, wechseln Sie bitte!

Was heißt dies für mich ansonsten? Was muss ich tun?

Spielen Sie die Updates Ihres Betriebssystems ein, wie es generell regelmäßig geschehen sollte (Anleitung zur Durchführung von Updates). In diesem Fall ist das "openssl"-Paket entscheidend, dass die veraltete Verschlüsselung abschaltet.

 

Falls möglich aktualisieren Sie Plesk auf Version 12.5.30, wenn Sie Plesk nutzen. Dies sichert die Serverdienste schon vollständig ab; es sind dann keine weiteren Änderungen erforderlich. Legen Sie vorher zur Sicherheit ein Backup an.

Ich nutze ein veraltetes System und möchte übergangsweise Anpassungen vornehmen. Was kann ich tun?

 

Bitte beachten Sie, dass wir das hier beschriebene Vorgehen nicht empfehlen. Es kann eine Grundlage für erfahrene Administratoren bieten, die sich über die Auswirkungen genau im Klaren sind! Dienste können dadurch unerreichbar werden!

Deaktivieren Sie SSLv2 (und gerne auch SSLv3), wenn dieses auf Ihrem System noch aktiviert ist. Dies müsste für alle Dienste geschehen, die auf Ihrem Server erreichbar sind. Hier einige Beispiele für die nötige Konfigurationsändern: 

  • Apache: Ersetzen Sie in Ihrer Apache-Konfiguration unter /etc/apache2/mods-enabled/ssl.conf die Zeile "SSLProtocol" durch
    SSLProtocol All -SSLv2 -SSLv3
  • Qmail: Qmail unterstützt das aktuellere TLS nicht so das eine sichere Konfiguration nicht möglich ist. Wechseln Sie bitte auf Postfix. Dies gelingt unter Plesk normalerweise mittels
    /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component postfix
  • Courier-IMAP: Ersetzen Sie in /etc/courier/imapd-ssl die Optionen
    IMAPDSSLSTART=NO
    IMAPDSTARTTLS=YES
    IMAP_TLS_REQUIRED=1
    TLS_PROTOCOL=TLS1
    TLS_STARTTLS_PROTOCOL=TLS1
  • Dovecot: Legen Sie die Datei /etc/dovecot/conf.d/99-drown.conf an und fügen Sie die Zeile hinzu
    ssl_protocols = !SSLv2 !SSLv3
  • Nginx: Ersetzen Sie in Ihrer Konfiguration die Zeile "ssl_protocols" durch
    ssl_protocols TLSv1 TLSv1.1 TLSv1.2

Sonstige Informationen:

Weitere technische Informationen, zum Angriff selbst und zur Absicherung dagegen, finden Sie unter:

drownattack.com

www.openssl.org/blog/blog/2016/03/01/an-openssl-users-guide-to-drown/

http://www.heise.de/security/meldung/DROWN-Angriff-SSL-Protokoll-aus-der-Steinzeit-wird-Servern-zum-Verhaengnis-3121121.html



This is an english summary of the article above.


In February 2016 a vulnerability in the ssl encryption under the name of "Drown" (RSA Decrypting with Obsolete and Weakened Encryption, CVE-2016-0800) has been found. This vulnerability allows an attacker to decrypt sensitive data from encrypted connections between a server and a client. Base for this attack is the serverside support for the obsolete SSLv2 protocol which in this case will also make safer protocols like TLS vulnerable.

What can i do if i use an End-Of-Life operating system?

Updates are only released for operating systems which are not yet End-Of-Life. An overview on lifecycles for our operating systems can be found here. If your operating system is already End-Of-Life you should do a product change (product change for virtual servers). If you use Ubuntu 10.04 (or earlier) or Debian 6 (or older), please switch your system!

What else should i do?

First of all you should install all open updates for your current operating system.

 

If possible and if you use Plesk, update your Plesk to version 12.5.30. This secures all services by default, no further changes are required! In advance you should create a backup.

I use an outdated system I want to manually and temporary secure. What could I do?

Please be aware that we do not recommand this action. I might be used as a basis for experienced administrators who are aware of the implications. Services can become unreachable!

Deactivate SSLv2 (in addition also SSLv3) if it is still used on your server. This has to be done for all services which use an encrypted connection.

Examples for possible modifications:

  • Apache webserver: Replace the row with "SSLProtocol" in your configuration file /etc/apache2/mods-enabled/ssl.conf with SSLProtocol All -SSLv2 -SSLv3
  • Postfix: drownattack.com/postfix.html
  • Qmail: Qmail doesn't support the current TLS, so please change your mailserver to Postfix for a safe configuration. this can be achieved using
  • /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component postfix
  • Courier-IMAP: Replace in your configuration file /etc/courier/imapd-ssl the following options
  • Dovecot: Create the file /etc/dovecot/conf.d/99-drown.conf and add the following ssl_protocols = !SSLv2 !SSLv3
  • Nginx: replace the row "ssl_protocols" with ssl_protocols TLSv1 TLSv1.1 TLSv1.2

 

Additional informationen

The most recent version of Plesk (12.5.30 and higher) is not affected and doesn't use SSLv2 in standard configuration.

More technical information about the vulnerability can be found under:

https://drownattack.com/

https://www.openssl.org/blog/blog/2016/03/01/an-openssl-users-guide-to-drown/


otto.friedrich@hosteurope.de xanthippe.ypsilante@hosteurope.de hercules.ikarus@hosteurope.de